Get in touch
Back
Resolved

Service restored

Started 21 Jun at 09:23am BST.

API Patient Portal Clinical Portal
Created

Some Ultramed services experienced intermittent high error rates this morning. We apologise for any inconvenience caused.

The increased error rates were caused by a global disruption to our Content Delivery Network provider, Cloudflare, which has now been resolved.

All our systems are now working as expected and we will be monitoring the situation further.

Posted 21 Jun at 09:23am BST.